GitHub header

GitHub audit logs are unavailable

Incident Report for GitHub

Resolved

On April 1, 2026, between 15:34 UTC and 16:02 UTC, our audit log service lost connectivity to its backing data store due to a failed credential rotation. During this 28-minute window, audit log history was unavailable via both the API and web UI. This resulted in 5xx errors for 4,297 API actors and 127 github.com users. Additionally, events created during this window were delayed by up to 29 minutes in github.com and event streaming. No audit log events were lost; all audit log events were ultimately written and streamed successfully. Customers using GitHub Enterprise Cloud with data residency were not impacted by this incident.

We were alerted to the infrastructure failure at 15:40 UTC — six minutes after onset — and resolved the issue by recycling the affected environment, restoring full service by 16:02 UTC. We are conducting a thorough review of our credential rotation process to strengthen its resiliency and prevent recurrence. In parallel, we are strengthening our monitoring capabilities to ensure faster detection and earlier visibility into similar issues going forward.
Posted Apr 01, 2026 - 16:10 UTC

Update

A routine credential rotation has failed for our our audit logs service; we have re-deployed our service and are waiting for recovery.
Posted Apr 01, 2026 - 16:07 UTC

Investigating

We are investigating reports of impacted performance for some GitHub services.
Posted Apr 01, 2026 - 16:06 UTC