GitHub header

Degraded Performance for GitHub Actions MacOS Runners

Incident Report for GitHub

Resolved

This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Posted Oct 01, 2025 - 16:55 UTC

Update

We are seeing some recovery for image queueing and continuing to monitor.
Posted Oct 01, 2025 - 16:27 UTC

Update

We are continuing work to restore capacity for our MacOS ARM runners.
Posted Oct 01, 2025 - 14:41 UTC

Update

Our team continues to work hard on restoring capacity for the Mac runners.
Posted Oct 01, 2025 - 13:58 UTC

Update

Work continues on restoring capacity on the Mac runners.
Posted Oct 01, 2025 - 13:12 UTC

Update

MacOS ARM runners continue to be at reduced capacity, causing queuing of jobs. Investigation is ongoing.
Posted Oct 01, 2025 - 12:32 UTC

Update

Work continues to bring the full runner capacity back online. Resources are focused on improving the recovery of certain runner types.
Posted Oct 01, 2025 - 11:51 UTC

Update

We are continuing to see recovery of some runner capacity and investigating slow recovery of certain runner types.
Posted Oct 01, 2025 - 11:11 UTC

Update

We are seeing recovery of some runner capacity, while also investigating slow recovery of certain runner types.
Posted Oct 01, 2025 - 10:30 UTC

Update

MacOS runners are coming back online and starting to process queued work.
Posted Oct 01, 2025 - 09:44 UTC

Update

We are continuing to deploy the necessary changes to restore MacOS runner capacity.
Posted Oct 01, 2025 - 08:59 UTC

Update

We have identified the cause and are deploying a change to restore MacOS runner capacity.
Posted Oct 01, 2025 - 08:27 UTC

Update

Customers using GitHub Actions Mac OS runners are experiencing job start delays and failures. We are aware of this issue and actively investigating.
Posted Oct 01, 2025 - 08:17 UTC

Update

Actions is experiencing degraded performance. We are continuing to investigate.
Posted Oct 01, 2025 - 08:09 UTC

Investigating

We are currently investigating this issue.
Posted Oct 01, 2025 - 07:59 UTC
This incident affected: Actions.