GitHub header

Degraded Codespaces experience

Incident Report for GitHub

Update

Codespaces IPs are no longer being blocked from Visual Studio Marketplace operations and we are monitoring for full recovery
Posted Mar 12, 2026 - 17:59 UTC

Update

We're seeing intermittent failures downloading from the extension marketplace from codespaces, caused by IP blocks for some codespaces. We're working to remove those blocks.
Posted Mar 12, 2026 - 17:20 UTC

Update

We're seeing intermittent failures downloading from the extension marketplace from codespaces and are investigating.
Posted Mar 12, 2026 - 16:09 UTC

Update

We're seeing partial recovery for the issue affecting extension installation in newly created Codespaces. Some users may still experience degraded functionality where extensions hit errors. The team continues to investigate the root cause while monitoring the recovery.
Posted Mar 12, 2026 - 15:08 UTC

Update

We have deployed a fix for the issue affecting extension installation in newly created Codespaces. New Codespaces are now being created with working extensions. We'll post another update by 15:30 UTC.
Posted Mar 12, 2026 - 14:29 UTC

Update

We are continuing to investigate an issue where extensions fail to install in newly created Codespaces. Users can create and access Codespaces, but extensions will not be operational, resulting in a degraded experience. The team is working on a fix. All newly created Codespaces are affected. We'll post another update by 15:00 UTC.
Posted Mar 12, 2026 - 13:50 UTC

Update

We're investigating an issue where extensions fail to install in newly created Codespaces. Users can still create and access Codespaces, but extensions will not be operational, resulting in a degraded development experience. Our team is actively working to identify and resolve the root cause. We'll post another update by 14:00 UTC.
Posted Mar 12, 2026 - 13:07 UTC

Investigating

We are investigating reports of degraded performance for Codespaces
Posted Mar 12, 2026 - 13:06 UTC
This incident affects: Codespaces.