GitHub header

Delayed visibility of newly added issues on project boards

Incident Report for GitHub

Update

The impact extends beyond adding issues to project boards. Adding pull requests and updating fields such as "Status" may also be affected. We're continuing to investigate the root cause.
Posted Mar 03, 2026 - 00:05 UTC

Update

Newly added issues are taking 30–60 minutes to appear on project boards, compared to the normal near-real-time behavior. We're investigating the root cause and possible mitigations.
Posted Mar 02, 2026 - 23:46 UTC

Update

Newly added issues can take up to 30 minutes to appear on project boards. We're investigating the cause of this delay.
Posted Mar 02, 2026 - 23:12 UTC

Update

Issues is experiencing degraded performance. We are continuing to investigate.
Posted Mar 02, 2026 - 23:11 UTC

Investigating

We are investigating reports of impacted performance for some GitHub services.
Posted Mar 02, 2026 - 23:10 UTC
This incident affects: Issues.