GitHub header

Incident with Actions

Incident Report for GitHub

Update

We are working with our compute provider to alleviate elevated queue times and failures for Actions Jobs running on Hosted Runners in the East US region affecting 10% of runs. Hosted Runners with private networking can fail over to a different Region to mitigate the issue.
Posted May 05, 2026 - 15:12 UTC

Update

We are investigating elevated queue times and failures on Actions Jobs running on Hosted Runners in East US affecting 8% of runs. Hosted Runners with private networking can fail over to a different Azure region to mitigate the issue.
Posted May 05, 2026 - 14:14 UTC

Update

We are investigating elevated queue times on Actions Jobs running on Standard Hosted Runners in East US affecting 10% of runs
Posted May 05, 2026 - 13:48 UTC

Investigating

We are investigating reports of degraded availability for Actions
Posted May 05, 2026 - 13:37 UTC
This incident affects: Actions.