GitHub header
We are investigating reports of degraded performance.
Incident Report for GitHub
Resolved
On December 26, 2023, GitHub received a report through our Bug Bounty Program demonstrating a vulnerability which, if exploited, allowed access to credentials within a production container. We fixed this vulnerability on GitHub.com the same day and began rotating all potentially exposed credentials. Through this process we found some flaws in how we rotate certain credentials and are working on improving our credential rotation process. More detail can be found on our blog: https://github.blog/2024-01-16-rotating-credentials-for-github-com-and-new-ghes-patches/
Posted Dec 29, 2023 - 21:21 UTC
Update
We are in the process of reverting a change that introduced these failures.
Posted Dec 29, 2023 - 21:09 UTC
Update
We’re investigating reports of increased failure rates for migrations with GitHub Enterprise Importer and exports using the Organization Migrations REST API.
Posted Dec 29, 2023 - 20:05 UTC
Investigating
We are currently investigating this issue.
Posted Dec 29, 2023 - 20:05 UTC