GitHub header

Disruption with actions hosted runners

Incident Report for GitHub

Resolved

This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Posted Jul 22, 2026 - 22:09 UTC

Monitoring

The degradation affecting Actions has been mitigated. We are monitoring to ensure stability.
Posted Jul 22, 2026 - 22:01 UTC

Update

The degradation affecting Actions has been mitigated. We are monitoring to ensure stability.
Posted Jul 22, 2026 - 22:01 UTC

Update

Approximately 3% of GitHub Actions runs on GitHub-hosted runners are experiencing run start delays exceeding 5 minutes. A small portion of these runs may fail after extended delays. We have identified the cause and are working on a mitigation.
Posted Jul 22, 2026 - 20:47 UTC

Investigating

We are investigating reports of degraded performance for Actions
Posted Jul 22, 2026 - 20:43 UTC
This incident affected: Actions.