GitHub header
Incident with Codespaces start and creation
Incident Report for GitHub
Resolved
On September 24th, 2024 from 08:20 UTC to 09:04 UTC the Codespaces service experienced an interruption in network connectivity, leading to 175 codespaces being unable to be created or resumed. The overall error rate during this period was 25%.

The cause was traced to an interruption in network connectivity caused by SNAT port exhaustion following a deployment, causing individual Codespaces to lose their connection to the service.

To mitigate the impact, we increased port allocations to give enough buffer for increased outbound connections shortly after deployments, and will be scaling up our outbound connectivity in the near future, as well as adding improved monitoring of network capacity to prevent future regressions.
Posted Sep 24, 2024 - 21:04 UTC
Update
Codespaces is operating normally.
Posted Sep 24, 2024 - 21:04 UTC
Update
We have successfully mitigated the issue affecting create and resume requests for Codespaces. Early signs of recovery are being observed in the impacted region.
Posted Sep 24, 2024 - 21:01 UTC
Update
Codespaces is experiencing degraded performance. We are continuing to investigate.
Posted Sep 24, 2024 - 21:00 UTC
Update
We are investigating issues with Codespaces in the US East geographic area. Some users may not be able to create or start their Codespaces at this time. We will update you on mitigation progress.
Posted Sep 24, 2024 - 20:56 UTC
Investigating
We are investigating reports of degraded availability for Codespaces
Posted Sep 24, 2024 - 20:54 UTC
This incident affected: Codespaces.