GitHub header

Errors starting and connecting to Codespaces

Incident Report for GitHub

Resolved

This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Posted Mar 16, 2026 - 15:28 UTC

Update

Errors starting or resuming Codespaces have resolved.
Posted Mar 16, 2026 - 15:27 UTC

Update

We are investigating reports of users experiencing errors when starting or connecting to Codespaces. Some users may be unable to access their development environments during this time. We are working to identify the root cause and will implement a fix as soon as possible.
Posted Mar 16, 2026 - 15:06 UTC

Investigating

We are investigating reports of impacted performance for some GitHub services.
Posted Mar 16, 2026 - 15:01 UTC