GitHub header
Incident with Codespaces
Incident Report for GitHub
Resolved
From January 5th to January 8th, Codespaces experienced issues with port forwarding when connecting from a web browser. During this incident 100% of operations to forward ports and connect to a forwarded port failed for customers located in US West and Australia. The cause was due to a cross origin API change in our port forwarding service. After detecting the issue, we mitigated the impact by rolling back the change that caused the discrepancy in the cross origin rules. We have improved the way we are detecting issues like this one including implementing automated alerts during and after the rollout process so that we get signals as early as possible.
Posted Jan 08, 2024 - 23:41 UTC
Update
The initial mitigation we attempted did not fully resolve this issue. We are continuing to investigate and will provide an update as soon as possible.
Posted Jan 08, 2024 - 22:37 UTC
Update
We are engaged on the issue and continuing to work toward a mitigation. Please continue to fallback to VS Code desktop for port forwarding workflows.
Posted Jan 08, 2024 - 21:55 UTC
Update
Mitigation of degraded Codespaces port forwarding in is progress. In the meantime, please continue to use VS Code Desktop for port forwarding.
Posted Jan 08, 2024 - 21:03 UTC
Update
We are actively mitigating degraded performance of Codespaces port forwarding in the web and GitHub CLI. Codespaces port forwarding on VS Code Desktop is unaffected.
Posted Jan 08, 2024 - 20:22 UTC
Investigating
We are investigating reports of degraded performance for Codespaces
Posted Jan 08, 2024 - 20:22 UTC
This incident affected: Codespaces.