GitHub header

Investigating errors on GitHub

Incident Report for GitHub

Resolved

This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Posted Apr 23, 2026 - 15:18 UTC

Monitoring

The degradation affecting Actions, Codespaces, Copilot and Packages has been mitigated. We are monitoring to ensure stability.
Posted Apr 23, 2026 - 15:02 UTC

Update

A mitigation was applied and services have recovered.  Actions is working through queued work before fully recovering.
Posted Apr 23, 2026 - 15:02 UTC

Update

Users are experiencing errors loading various web pages on github.com. Actions and Copilot Cloud Agent runs will be delayed.
Posted Apr 23, 2026 - 14:51 UTC

Update

Copilot is experiencing degraded performance. We are continuing to investigate.
Posted Apr 23, 2026 - 14:44 UTC

Update

Codespaces is experiencing degraded performance. We are continuing to investigate.
Posted Apr 23, 2026 - 14:42 UTC

Update

Packages is experiencing degraded performance. We are continuing to investigate.
Posted Apr 23, 2026 - 14:41 UTC

Investigating

We are investigating reports of degraded performance for Actions
Posted Apr 23, 2026 - 14:40 UTC
This incident affected: Actions, Packages, Copilot, and Codespaces.