GitHub header

Issues with Copilot Coding Agent

Incident Report for GitHub

Resolved

This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Posted Mar 19, 2026 - 14:32 UTC

Update

Copilot is operating normally.
Posted Mar 19, 2026 - 14:06 UTC

Update

We are investigating reports that Copilot Coding Agent session logs are not available in the UI.
Posted Mar 19, 2026 - 14:02 UTC

Update

Copilot is experiencing degraded performance. We are continuing to investigate.
Posted Mar 19, 2026 - 13:45 UTC

Investigating

We are investigating reports of impacted performance for some GitHub services.
Posted Mar 19, 2026 - 13:44 UTC
This incident affected: Copilot.