GitHub header

Team synchronization is experiencing delays for non enterprise managed users

Incident Report for GitHub

Resolved

This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Posted Dec 05, 2025 - 22:20 UTC

Update

We believe we reached a scaling limit and are increasing the amount of resources available to reduce the delays for the team synchronization process.
Posted Dec 05, 2025 - 21:40 UTC

Update

We're continuing to investigate the delays in the team synchronization and will report back once we have more information.
Posted Dec 05, 2025 - 19:17 UTC

Investigating

We are investigating reports of impacted performance for some GitHub services.
Posted Dec 05, 2025 - 18:38 UTC