GitHub header

Creating GitHub apps using the REST API will fail with a 401 error

Incident Report for GitHub

Resolved

This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Posted Sep 16, 2025 - 17:45 UTC

Update

We have mitigated the issue and are monitoring the results
Posted Sep 16, 2025 - 17:27 UTC

Update

A recent change to our API routing inadvertently added an authentication requirement to the anonymous route for creating GitHub apps. We're in the process of fixing the change, but in the interim retrying should eventually succeed.
Posted Sep 16, 2025 - 17:15 UTC

Investigating

We are currently investigating this issue.
Posted Sep 16, 2025 - 17:14 UTC