GitHub header

Disruption with some GitHub services

Incident Report for GitHub

Resolved

On May 16th, 2025, between 08:42:00 UTC and 12:26:00 UTC, the data store powering the Audit Log API service experienced elevated latency resulting in higher error rates due to timeouts. About 3.8% of Audit Log API queries for Git events experienced timeouts. The data store team deployed mitigating actions which resulted in a full recovery of the data store’s availability.
Posted May 16, 2025 - 15:24 UTC

Update

We are investigating issues with the audit log. Users querying Git audit log data may observe increased latencies and occasional timeouts.
Posted May 16, 2025 - 10:22 UTC

Investigating

We are currently investigating this issue.
Posted May 16, 2025 - 09:22 UTC