GitHub header

Incident with Git Operations

Incident Report for GitHub

Resolved

On May 8, 2025, between 14:40 UTC and 16:27 UTC the Git Operations service was degraded causing some pushes and merges to fail. On average, the error rate was 1.4% with a peak error rate of 2.24%. This was due to a configuration change which unexpectedly led a critical service to shut down on a subset of hosts that store repository data.

We mitigated the incident by re-deploying the affected service to restore its functionality.

In order to prevent similar incidents from happening again, we identified the cause that triggered this behavior and mitigated it for future deployments. Additionally, to reduce time to detection we will improve monitoring of the impacted service.
Posted May 08, 2025 - 16:27 UTC

Update

Pull Requests is operating normally.
Posted May 08, 2025 - 16:18 UTC

Update

Actions is operating normally.
Posted May 08, 2025 - 16:12 UTC

Update

We have identified the issue and applied mitigations, and are monitoring for recovery.
Posted May 08, 2025 - 16:03 UTC

Update

Actions is experiencing degraded performance. We are continuing to investigate.
Posted May 08, 2025 - 15:23 UTC

Investigating

We are investigating reports of degraded performance for Git Operations and Pull Requests
Posted May 08, 2025 - 15:20 UTC
This incident affected: Git Operations, Pull Requests, and Actions.