GitHub header
Incident with Git Operations and Pull Requests
Incident Report for GitHub
Resolved
At 2023-12-18 20:03 UTC, our monitoring flagged an increase in GitRPC response errors that resulted from a change that was made that caused backend replicas to temporarily become out of sync while the change was deployed. During this time, approximately 2,500 users across 8,200 repos would have seen the merge button disabled or received failures from the merge API endpoint.

Upon discovering the failures, our engineers assessed that the shortest path to resolution was to roll forward and manually deploy to the remaining hosts, which resolved the issue at 2023-12-18 21:26.
Posted Dec 18, 2023 - 21:26 UTC
Update
Git Operations is operating normally.
Posted Dec 18, 2023 - 21:26 UTC
Update
We're seeing issues related to Pull Requests impacting a small number of users. We are aware deploying a fix and expect to resolve within the next 60 minutes.
Posted Dec 18, 2023 - 21:19 UTC
Investigating
We are investigating reports of degraded performance for Git Operations and Pull Requests
Posted Dec 18, 2023 - 21:17 UTC
This incident affected: Git Operations and Pull Requests.