GitHub header

Disruption with some GitHub services

Incident Report for GitHub

Resolved

This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Posted Dec 18, 2025 - 19:09 UTC

Update

Copilot is operating normally.
Posted Dec 18, 2025 - 19:09 UTC

Update

We have observed full recovery with updating copilot policy settings, and are validating that that there is no further impact.
Posted Dec 18, 2025 - 19:05 UTC

Update

Copilot is experiencing degraded performance. We are continuing to investigate.
Posted Dec 18, 2025 - 18:43 UTC

Update

We have identified the source of this regression and are preparing a fix for deployment. We will update again in one hour.
Posted Dec 18, 2025 - 18:10 UTC

Update

We are seeing an increase in errors on the User and Org policy settings page when updating policies. The errors are affecting the user copilot policies settings page, org copilot policies settings page when updating a policy.
Posted Dec 18, 2025 - 17:36 UTC

Investigating

We are investigating reports of impacted performance for some GitHub services.
Posted Dec 18, 2025 - 17:36 UTC
This incident affected: Copilot.