GitHub header

Actions workflow run and job status updates are experiencing delays

Incident Report for GitHub

Resolved

This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Posted Jan 15, 2026 - 15:26 UTC

Update

We are continuing to monitor as the system recovers and expect full recovery within the next 20-30 minutes. Impacted users will see that job status appears queued, though the job itself is actually running.
Posted Jan 15, 2026 - 15:12 UTC

Update

We are seeing signs of recovery and are continuing to monitor as we process the backlog of events.
Posted Jan 15, 2026 - 14:55 UTC

Investigating

We are investigating reports of degraded performance for Actions
Posted Jan 15, 2026 - 14:24 UTC
This incident affected: Actions.