This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Posted Jun 04, 2026 - 19:59 UTC
Update
This issue is now fully resolved and Copilot Code Review is working as expected.
Posted Jun 04, 2026 - 19:59 UTC
Update
The mitigation for Copilot Code Review is now fully deployed, and new reviews are working as expected. We are continuing to monitor for full resolution.
Customers may need to re-request Copilot Code Review. Copilot Code Review Actions runs running for longer than 20 minutes may be safely cancelled.
Posted Jun 04, 2026 - 19:41 UTC
Monitoring
The degradation has been mitigated. We are monitoring to ensure stability.
Posted Jun 04, 2026 - 19:07 UTC
Update
The mitigation for Copilot Code Review is now fully deployed, and new reviews are working as expected.
Customers may need to re-request Copilot Code Review. Copilot Code Review Actions runs running for longer than 20 minutes may be safely cancelled.
Posted Jun 04, 2026 - 19:07 UTC
Update
The mitigation for Copilot Code Review is rolling out and we are seeing early signs of recovery.
Posted Jun 04, 2026 - 18:52 UTC
Update
We have identified that Copilot Code Review users may see "Copilot ran into an error" on Pull Requests that requested Copilot Code Review.
A mitigation is in progress, we expect mitigation in approximately 30m.
GitHub Enterprise Cloud with Data Residency is not impacted.
Posted Jun 04, 2026 - 18:22 UTC
Update
We have identified that Copilot Code Review. Users may see "Copilot ran into an error" on Pull Requests that requested Copilot Code Review.
A mitigation is in progress.
Posted Jun 04, 2026 - 18:03 UTC
Investigating
We are investigating reports of impacted performance for some GitHub services.