GitHub header

Git operation failures

Incident Report for GitHub

Update

We have shipped a fix and are seeing recovery in some areas and will continue to provide updates.
Posted Nov 18, 2025 - 21:36 UTC

Update

We have identified the likely cause of the incident and are working on a fix. We will provide another update as we get closer to deploying the fix.
Posted Nov 18, 2025 - 21:27 UTC

Update

Codespaces is experiencing degraded availability. We are continuing to investigate.
Posted Nov 18, 2025 - 21:25 UTC

Update

We are currently investigating failures on all Git operations, including both SSH and HTTP.
Posted Nov 18, 2025 - 21:11 UTC

Update

We are seeing failures for some git http operations and are investigating
Posted Nov 18, 2025 - 20:52 UTC

Update

Git Operations is experiencing degraded availability. We are continuing to investigate.
Posted Nov 18, 2025 - 20:39 UTC

Investigating

We are currently investigating this issue.
Posted Nov 18, 2025 - 20:39 UTC
This incident affects: Git Operations and Codespaces.