GitHub header

Incident with Issues, API Requests and Pull Requests

Incident Report for GitHub

Resolved

This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Posted Jul 29, 2025 - 02:06 UTC

Update

Pull Requests is operating normally.
Posted Jul 29, 2025 - 02:05 UTC

Update

Mitigation has deployed. We are seeing recovery across all impacted services.
Posted Jul 29, 2025 - 02:04 UTC

Update

Issues is operating normally.
Posted Jul 29, 2025 - 02:03 UTC

Update

Team is deploying a mitigation for this incident. We will update again once we have verified the fix.
Posted Jul 29, 2025 - 01:52 UTC

Update

Approximately 4% of requests to impacted services continue to error. The team is continuing its work to mitigate this incident.
Posted Jul 29, 2025 - 00:51 UTC

Update

Team is continuing to look into networking issues. We will keep users updated on progress towards mitigation.
Posted Jul 29, 2025 - 00:02 UTC

Update

Some GitHub services continue to experience degraded performance. Team is looking into networking issues. We will continue to keep users updated on progress towards mitigation.
Posted Jul 28, 2025 - 23:18 UTC

Update

Some GitHub services are experiencing degraded performance. Team is currently investigating to determine a cause and mitigation.
Posted Jul 28, 2025 - 22:42 UTC

Investigating

We are investigating reports of degraded performance for API Requests, Issues and Pull Requests
Posted Jul 28, 2025 - 22:40 UTC
This incident affected: API Requests, Issues, and Pull Requests.