GitHub header

Increased latency with webhooks

Incident Report for GitHub

Resolved

This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Posted Jun 15, 2026 - 17:37 UTC

Monitoring

The degradation affecting Webhooks has been mitigated. We are monitoring to ensure stability.
Posted Jun 15, 2026 - 16:39 UTC

Update

Webhooks delivery latency has returned to normal levels. The backlog that built up during the incident has been cleared at approximately 4:29 UTC. We consider this incident resolved.
Posted Jun 15, 2026 - 16:39 UTC

Investigating

We are investigating reports of degraded performance for Webhooks
Posted Jun 15, 2026 - 15:37 UTC
This incident affected: Webhooks.