GitHub header

Codespaces billing is delayed

Incident Report for GitHub

Resolved

This incident has been resolved.
Posted Jun 10, 2025 - 19:08 UTC

Update

We've increased capacity to process the codespaces billing jobs and see are seeing recovery, we expect a full mitigation within the hour.
Posted Jun 10, 2025 - 18:21 UTC

Investigating

We are currently investigating this issue.
Posted Jun 10, 2025 - 17:47 UTC