GitHub header

Incident with Issues and Webhooks

Incident Report for GitHub

Resolved

This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Posted May 04, 2026 - 16:40 UTC

Monitoring

The degradation has been mitigated. We are monitoring to ensure stability.
Posted May 04, 2026 - 16:36 UTC

Update

Webhooks is operating normally.
Posted May 04, 2026 - 16:35 UTC

Update

The degradation affecting Codespaces has been mitigated. We are monitoring to ensure stability.
Posted May 04, 2026 - 16:35 UTC

Update

The degradation affecting Issues has been mitigated. We are monitoring to ensure stability.
Posted May 04, 2026 - 16:34 UTC

Update

Pull Requests is operating normally.
Posted May 04, 2026 - 16:32 UTC

Update

Pages is operating normally.
Posted May 04, 2026 - 16:29 UTC

Update

Latency across services has normalized. We are continuing to investigate the root cause and prevent reoccurrence.
Posted May 04, 2026 - 16:29 UTC

Update

Actions and Packages are operating normally.
Posted May 04, 2026 - 16:28 UTC

Update

Git Operations is operating normally.
Posted May 04, 2026 - 16:25 UTC

Update

Pages is experiencing degraded performance. We are continuing to investigate.
Posted May 04, 2026 - 16:06 UTC

Update

Codespaces is experiencing degraded performance. We are continuing to investigate.
Posted May 04, 2026 - 16:05 UTC

Update

Pull Requests is experiencing degraded performance. We are continuing to investigate.
Posted May 04, 2026 - 15:56 UTC

Update

Actions is experiencing degraded performance. We are continuing to investigate.
Posted May 04, 2026 - 15:51 UTC

Update

Pull Requests is experiencing degraded availability. We are continuing to investigate.
Posted May 04, 2026 - 15:51 UTC

Update

Packages is experiencing degraded performance. We are continuing to investigate.
Posted May 04, 2026 - 15:50 UTC

Update

Git Operations is experiencing degraded performance. We are continuing to investigate.
Posted May 04, 2026 - 15:48 UTC

Update

We are investigating Increased latency and timeouts across multiple GitHub services.
Posted May 04, 2026 - 15:48 UTC

Investigating

We are investigating reports of degraded performance for Issues and Webhooks
Posted May 04, 2026 - 15:45 UTC
This incident affected: Git Operations, Webhooks, Issues, Pull Requests, Actions, Packages, Pages, and Codespaces.