GitHub header

Degraded experience with Copilot Code Review

Incident Report for GitHub

Resolved

This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Posted Mar 11, 2026 - 15:53 UTC

Update

Copilot Code Review queue processing has returned to normal levels.
Posted Mar 11, 2026 - 15:53 UTC

Update

We experienced degraded performance with Copilot Code Review starting at 14:01 UTC. Customers experienced extended review times and occasional failures. Some extended processing times may continue briefly. We are monitoring for full recovery. We'll post another update by 16:30 UTC.
Posted Mar 11, 2026 - 15:31 UTC

Monitoring

We are investigating degraded performance with Copilot Code Review. Customers may experience extended review times or occasional failures. We are seeing signs of improvement as our team works to restore normal service. We'll post another update by 15:30 UTC.
Posted Mar 11, 2026 - 14:28 UTC

Investigating

We are investigating reports of impacted performance for some GitHub services.
Posted Mar 11, 2026 - 14:25 UTC