GitHub header
Incident with Pull Request Rebase Merges
Incident Report for GitHub
Resolved
This incident has been resolved.
Posted Jan 16, 2025 - 09:40 UTC
Update
The incident has been resolved, but please note affected pull requests will self repair when any commits are pushed to the pull requests' base branch or head branch. If you encounter problems with a rebase and merge, either click the "update branch" button or push a commit to the PR's branch.
Posted Jan 16, 2025 - 09:39 UTC
Update
We have mitigated the incident, and any new pull request rebase merges should be recovered. We are working on recovery steps for any pull requests that attempted to merge during this incident.
Posted Jan 16, 2025 - 09:18 UTC
Update
We believe to have found a root cause, and in the process of verifying the mitigation.
Posted Jan 16, 2025 - 08:37 UTC
Update
We are still continuing to investigate.
Posted Jan 16, 2025 - 07:38 UTC
Update
We are still experiencing failures for rebase merges in pull requests, we are continuing to investigate.
Posted Jan 16, 2025 - 07:05 UTC
Investigating
We are investigating reports of degraded performance for Pull Requests
Posted Jan 16, 2025 - 06:22 UTC
This incident affected: Pull Requests.