GitHub header
Incident with Codespaces
Incident Report for GitHub
Resolved
On 2024-01-21 at 3:38 UTC, we experienced an incident that affected customers using Codespaces. Customers encountered issues creating and resuming Codespaces in multiple regions due to operational issues with compute and storage resources.

Around 25% of customers were impacted, primarily in East US and West Europe. We re-routed traffic for Codespace creations to less impacted regions, but existing Codespaces in these regions may have been unable to resume during the incident.

By 7:30 UTC, we had recovered connectivity to all regions except West Europe, which had an extended recovery time due to increased load in that particular region. The incident was resolved on 2024-01-21 at 9:34 UTC once Codespace creations and resumes were working normally in all regions.
Posted Jan 21, 2024 - 09:34 UTC
Update
We continue to work on mitigating the issues with Codespace resumes in West Europe.
Posted Jan 21, 2024 - 09:32 UTC
Update
We continue to work on mitigating the issues with Codespace resumes in West Europe.
Posted Jan 21, 2024 - 08:58 UTC
Update
We continue to work on mitigating the issues with Codespace resumes in West Europe.
Posted Jan 21, 2024 - 08:27 UTC
Update
Codespace creation has fully recovered in all regions. We are still mitigating issues with Codespace resumes in West Europe.
Posted Jan 21, 2024 - 07:55 UTC
Update
We continue to see recovery in most regions. We are still working on mitigating the issue impacting customers in West Europe.
Posted Jan 21, 2024 - 07:24 UTC
Update
We are continuing to monitor recovery in the affected regions.
Posted Jan 21, 2024 - 06:50 UTC
Update
We are seeing signs of recovery in the affected regions.
Posted Jan 21, 2024 - 06:15 UTC
Update
Codespaces is experiencing degraded performance. We are continuing to investigate.
Posted Jan 21, 2024 - 06:15 UTC
Update
We continue to work on mitigating the underlying the issue impacting Codespaces customers.
Posted Jan 21, 2024 - 06:00 UTC
Update
We continue to work on mitigating the underlying the issue impacting Codespaces customers.
Posted Jan 21, 2024 - 05:24 UTC
Update
Around 15% of Codespaces customers are unable to create or resume their codespaces. We are continuing efforts to mitigate the issue.
Posted Jan 21, 2024 - 04:50 UTC
Update
Codespaces is experiencing degraded availability. We are continuing to investigate.
Posted Jan 21, 2024 - 04:21 UTC
Update
We have identified the issue impacting Codespaces customers in multiple regions and are working on mitigation.
Posted Jan 21, 2024 - 04:15 UTC
Update
We are experiencing elevated error rates in multiple regions and are currently investigating.
Posted Jan 21, 2024 - 03:38 UTC
Investigating
We are investigating reports of degraded performance for Codespaces
Posted Jan 21, 2024 - 03:38 UTC
This incident affected: Codespaces.