GitHub header
Incident with Copilot
Incident Report for GitHub
Resolved
On March 11, 2024, between 06:30 UTC and 11:45 UTC the Copilot Chat service was degraded and customers may have encountered errors or timed out requests for chat interactions. On average, the error rate was 10% and peaked at 45% of requests to the service for short periods of time.

This was due to a gap in handling an edge case for messages returned from the underlying language models. We mitigated the incident by applying a fix to the handling of the streaming response.

We are working to update monitoring to reduce time to detection and increase resiliency to message format changes.
Posted Mar 11, 2024 - 10:20 UTC
Update
We are deploying mitigations for the failures we have been observing in some chat requests for Copilot. We will continue to monitor and update.
Posted Mar 11, 2024 - 10:02 UTC
Update
We are seeing an elevated failure rate for chat requests for Copilot. We are investigating and will continue to keep users updated on progress towards mitigation.
Posted Mar 11, 2024 - 09:03 UTC
Investigating
We are investigating reports of degraded performance for Copilot
Posted Mar 11, 2024 - 08:14 UTC
This incident affected: Copilot.