GitHub header
We are investigating reports of degraded performance.
Incident Report for GitHub
Resolved
An update to our design system caused issues loading dynamic content in the global side navigation menu and in other page-specific sidebar navigation elements. Impacted users saw continuous loading spinners in place of dynamic menu content. User impact lasted from 0:55 UTC to 4:41 UTC on February 1st.

We are working on a number of improvements in response to this incident. We are adding request volume monitors to sidebar navigation endpoints and making changes to our front end escalation paths to improve our time to detect and time to recovery for incidents of this nature. We have also begun work to improve both automated and manual testing for these types of changes in order to prevent recurrence.
Posted Feb 01, 2024 - 04:41 UTC
Update
This issue has been resolved. A reload of your browser window/tab may be required if you continue to experience issues with the collapsable navigation sidebars not loading.
Posted Feb 01, 2024 - 04:41 UTC
Update
We are in the process of deploying a remediation, and expect to see restoration of impacted functionality within the next hour.
Posted Feb 01, 2024 - 04:21 UTC
Update
We have identified an issue that is preventing some navigation components from loading while browsing GitHub.com, and are testing a remediation prior to deployment.
Posted Feb 01, 2024 - 03:55 UTC
Update
We are currently investigating reports of some components of the GitHub.com website not loading for some users.
Posted Feb 01, 2024 - 03:14 UTC
Investigating
We are currently investigating this issue.
Posted Feb 01, 2024 - 03:13 UTC