We have identified the issue causing Codespace create/resume actions to fail and are applying a fix. This is estimated to take ~2 hours to complete but impact will begin to reduce sooner than that.
We will continue to monitor recovery progress and will report back when more information is available.
Posted Feb 12, 2026 - 09:04 UTC
Update
We now understand the source of the VM create/resume failures and are working with our partners to mitigate the impact.
Posted Feb 12, 2026 - 08:32 UTC
Update
We are seeing an increase in Codespaces creation and resuming failures across multiple regions, primarily in EMEA. Our team are analysing the situation and are working to mitigate this impact.
While we are working, customers are advised to create Codespaces in US East and US West regions via the "New with options..." button when creating a Codespace.
More updates as we have them.
Posted Feb 12, 2026 - 08:02 UTC
Investigating
We are investigating reports of degraded availability for Codespaces