GitHub header

Disruption with Pull Request Ref Updates

Incident Report for GitHub

Resolved

This incident has been resolved.
Posted Apr 30, 2025 - 21:05 UTC

Update

Some customers of github.com are reporting issues with PR tracking refs not being updated due to processing delays and increased failure rates. We're investigating the source of the issue.
Posted Apr 30, 2025 - 20:53 UTC

Investigating

We are investigating reports of degraded performance for Pull Requests
Posted Apr 30, 2025 - 20:51 UTC
This incident affected: Pull Requests.