GitHub header

Increased Latency and Failures for SSH Git Operations

Incident Report for GitHub

Resolved

This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Posted May 05, 2026 - 18:35 UTC

Update

We've completed our mitigation to prevent further impact. At this time the incident is considered resolved.
Posted May 05, 2026 - 18:35 UTC

Monitoring

The degradation affecting Git Operations has been mitigated. We are monitoring to ensure stability.
Posted May 05, 2026 - 18:25 UTC

Update

We're continuing to work on preventing further impact from the earlier issue. No SSH-based impact is expected at this time. We'll post new updates if impact recurs or once our mitigation is in place.
Posted May 05, 2026 - 17:26 UTC

Investigating

Git Operations is experiencing degraded performance. We are continuing to investigate.
Posted May 05, 2026 - 17:23 UTC

Monitoring

Between approximately 14:00 and 16:10 UTC, customers using SSH-based Git operations may have experienced elevated latency and failures. HTTP-based operations were not impacted. We've identified a suspected root cause and are working to implement a mitigation to prevent further impact.
Posted May 05, 2026 - 16:54 UTC

Investigating

We are investigating reports of impacted performance for some GitHub services.
Posted May 05, 2026 - 16:49 UTC
This incident affected: Git Operations.