GitHub header

Incident with CodeQL

Incident Report for GitHub

Resolved

This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Posted May 13, 2026 - 16:03 UTC

Update

CodeQL impact has been mitigated. We are continuing to monitor for durable recovery.
Posted May 13, 2026 - 15:30 UTC

Monitoring

The degradation has been mitigated. We are monitoring to ensure stability.
Posted May 13, 2026 - 15:26 UTC

Update

We have applied a mitigation to increase processing capacity. We are continuing to monitor to confirm full recovery. We will provide another update by 15:30 UTC.
Posted May 13, 2026 - 14:58 UTC

Update

We are investigating delays affecting CodeQL, the code analysis engine used by Code Scanning. Some users may experience delayed or incomplete code scanning results. Our engineering team is investigating. We will provide another update by 15:15 UTC.
Posted May 13, 2026 - 14:43 UTC

Investigating

We are investigating reports of impacted performance for some GitHub services.
Posted May 13, 2026 - 14:41 UTC