GitHub header
We are investigating reports of degraded performance.
Incident Report for GitHub
Resolved
Between May 19th 3:40AM UTC and May 20th 5:40PM UTC the service responsible for rendering Jupyter notebooks was degraded. During this time customers were unable to render Jupyter Notebooks.

This occurred due to an issue with a Redis dependency which was mitigated by restarting. An issue with our monitoring led to a delay in our response. We are working to improve the quality and accuracy of our monitors to reduce the time to detection.
Posted May 20, 2024 - 17:05 UTC
Update
We are beginning to see recovery rendering Jupyter notebooks and are continuing to monitor.
Posted May 20, 2024 - 17:01 UTC
Update
Customers may experience errors viewing rendered Jupyter notebooks from PR diff pages or the files tab
Posted May 20, 2024 - 16:50 UTC
Investigating
We are currently investigating this issue.
Posted May 20, 2024 - 16:47 UTC