On Sunday April 13th, 2026, between 18:53 UTC and 20:30 UTC, the GitHub Pages service experienced elevated error rates. On average, the error rate was 10.58% and peaked at 12.77% of requests to the service, resulting in approximately 17.5 million failed requests returning HTTP 500 errors. This was due to an automated DNS management tool (octodns) erroneously deleting a DNS record for a Pages backend storage host after its upstream data source intermittently failed to return the record, causing the tool to treat it as stale and remove it.
We mitigated the incident by re-creating the deleted DNS record. To prevent future incidents, we are implementing availability-zone-tolerant routing in the Pages frontend so that an unresolvable backend host triggers failover to healthy hosts rather than returning errors, adding safeguards to prevent automated deletion of DNS records owned by other systems, and improving logging and alerting for DNS resolution failures in the Pages serving path.
Posted Apr 13, 2026 - 20:35 UTC
Update
We have mitigated the issue with Pages.
Posted Apr 13, 2026 - 20:32 UTC
Monitoring
The degradation affecting Pages has been mitigated. We are monitoring to ensure stability.
Posted Apr 13, 2026 - 20:30 UTC
Update
We are investigating reports of issues with Pages. We will continue to keep users updated on progress towards mitigation.
Posted Apr 13, 2026 - 19:57 UTC
Investigating
We are investigating reports of degraded availability for Pages