GitHub header

Partial Actions Cache degradation

Incident Report for GitHub

Resolved

This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Posted Jun 18, 2025 - 18:47 UTC

Update

We are continuing to rollout a mitigation and are progressing towards having this rolled out for all customers.
Posted Jun 18, 2025 - 18:11 UTC

Update

We are currently deploying a mitigation for this issue and will be rolling it out shortly. We will update our progress as we monitor the deployment.
Posted Jun 18, 2025 - 17:22 UTC

Update

We are actively investigating and working on a mitigation for database instability leading to replication lag in the Actions Cache service. We will continue to post updates on progress towards mitigation.
Posted Jun 18, 2025 - 17:03 UTC

Update

The actions cache service is experiencing degradation in a number of regions causing cache misses when attempting to download cache entries. This is not causing workflow failures, but workflow runtime might be elevated for certain runs.
Posted Jun 18, 2025 - 16:46 UTC

Investigating

We are currently investigating this issue.
Posted Jun 18, 2025 - 16:46 UTC