GitHub header

Issue Attachments Failing to Upload

Incident Report for GitHub

Resolved

On May 1, 2025 from 22:09 UTC to 23:13 UTC, the Issues service was degraded and users weren't able to upload attachments. The root cause was identified to be a new feature which added a custom header to all client-side HTTP requests, causing a CORS errors when uploading attachments to our provider.

We mitigated the incident by rolling back the feature flag that added the new header at 22:56 UTC. In order to prevent this from happening again, we are adding new metrics to monitor and ensure the safe rollout of changes to client-side requests.
Posted May 01, 2025 - 23:13 UTC

Update

We have identified the underlying cause of attachment upload failures to Issues and mitigated it by rolling back a feature flag. If you are still experiencing failures when uploading attachments to Issues, please reload your page.
Posted May 01, 2025 - 23:13 UTC

Update

We are investigating attachment upload failures on Issues. We will continue to keep users updated on progress towards mitigation.
Posted May 01, 2025 - 22:29 UTC

Investigating

We are investigating reports of degraded availability for Issues
Posted May 01, 2025 - 22:28 UTC
This incident affected: Issues.