GitHub header
Incident with Issues
Incident Report for GitHub
Resolved
On June 5, 2024, between 17:05 UTC and 19:27 UTC, the GitHub Issues service was degraded. During that time, no events related to projects were displayed on issue timelines. These events indicate when an issue was added to or removed from a project and when their status changed within a project. The data couldn’t be loaded due to a misconfiguration of the service backing these events. This happened after a scheduled secret rotation when the wrongly configured service continued using the old secrets which had expired.

We mitigated the incident by remediating the service configuration and have started simplifying the configuration to avoid similar misconfigurations in the future.
Posted Jun 05, 2024 - 19:27 UTC
Update
Issues is operating normally.
Posted Jun 05, 2024 - 19:27 UTC
Update
We continue to troubleshoot the problem with issues timeline.
Posted Jun 05, 2024 - 19:19 UTC
Update
We continue to troubleshoot the problem with issues timeline.
Posted Jun 05, 2024 - 18:47 UTC
Update
We're continuing to investigate the problem.
Posted Jun 05, 2024 - 18:01 UTC
Update
We're seeing issues related to the issues timeline service, we're investigating and we will continue to keep users updated on progress towards mitigation.
Posted Jun 05, 2024 - 17:26 UTC
Investigating
We are investigating reports of degraded availability for Issues
Posted Jun 05, 2024 - 17:22 UTC
This incident affected: Issues.