GitHub header

Incident with Codespaces

Incident Report for GitHub

Resolved

This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Posted Apr 16, 2026 - 18:28 UTC

Monitoring

The degradation affecting Codespaces has been mitigated. We are monitoring to ensure stability.
Posted Apr 16, 2026 - 18:22 UTC

Update

Our provider is implementing a mitigation and we are seeing signs of recovery.
Posted Apr 16, 2026 - 16:37 UTC

Update

We found an issue that impacts 70% of Codespaces. We are engaged with the provider and working towards mitigation.
Posted Apr 16, 2026 - 15:49 UTC

Update

Codespaces is experiencing degraded availability. We are continuing to investigate.
Posted Apr 16, 2026 - 15:41 UTC

Update

We are experiencing degraded performance in Codespaces related to creating a new Codespace or starting an existing Codespace from the VS Code editor. SSH connections to Codespaces are not impacted. We are working toward mitigation and will continue to keep you updated on progress.
Posted Apr 16, 2026 - 15:08 UTC

Investigating

We are investigating reports of degraded performance for Codespaces
Posted Apr 16, 2026 - 15:06 UTC
This incident affected: Codespaces.