GitHub header
We are investigating reports of degraded performance.
Incident Report for GitHub
Resolved
On January 23, 2024 at 14:36 UTC, our internal metrics began showing an increase in exceptions originating from our live update service. Live updates to Issues, PRs, Actions, and Projects were failing, but refreshing the page successfully updated page content. We resolved the issue by rolling back a problematic dependency update and reenabled live updates at 18:53 UTC.

We are working to improve alerting and monitoring of our live update service to reduce our time to detection and mitigation.
Posted Jan 23, 2024 - 18:53 UTC
Update
Live updates have been restored and the system is operating normally.
Posted Jan 23, 2024 - 18:53 UTC
Update
We have identified and are beginning to roll out a potential fix for issues with live updates to our Web UI that power automatic page updates such as the merge box on Pull Requests and updates to Projects.
Users will see actions spinning on the PR merge box for example. As a work around, please refresh the page to get the page updated while we work to fix the issue. We will provide further updates as we continue resolving the issue.
Posted Jan 23, 2024 - 18:14 UTC
Update
We are continuing to investigate issues with live updates to our Web UI that power automatic page updates such as the merge box on Pull Requests and updates to Projects.
Users will see actions spinning on the PR merge box for example. As a work around, please refresh the page to get the page updated while we work to fix the issue. We will provide further updates as we continue resolving the issue.
Posted Jan 23, 2024 - 17:17 UTC
Update
We are continuing to investigate intermittent issues with live updates to our Web UI that power automatic page updates such as the merge box on Pull Requests and updates to Projects. Users will see actions spinning on the PR merge box for example. As a work around, please refresh the page to get the page updated while we work to fix the issue. We will provide further updates as we continue resolving the issue.
Posted Jan 23, 2024 - 16:37 UTC
Update
We are investigating intermittent issues with live updates to our Web UI that power automatic page updates such as the merge box on Pull Requests. Users will intermittently see actions spinning on the PR merge box for example. As a work around, please refresh the page to get the page updated while we work to fix the issue. We will provide further updates as we continue resolving the issue.
Posted Jan 23, 2024 - 15:59 UTC
Investigating
We are currently investigating this issue.
Posted Jan 23, 2024 - 15:50 UTC