GitHub header

Incident with Actions

Incident Report for GitHub

Resolved

This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Posted Aug 21, 2025 - 18:13 UTC

Update

We've applied a mitigation to fix the issues with queuing and running Actions jobs. We are seeing improvements in telemetry and are monitoring for full recovery.
Posted Aug 21, 2025 - 17:58 UTC

Update

The team continues to investigate issues with some Actions jobs on Hosted Runners being queued for a long time and a percentage of jobs failing. We are increasing runner capacity and will continue providing updates on the progress towards mitigation.
Posted Aug 21, 2025 - 17:21 UTC

Update

The team continues to investigate issues with some Actions jobs on Hosted Runners being queued for a long time and a percentage of jobs failing. We will continue providing updates on the progress towards mitigation.
Posted Aug 21, 2025 - 16:43 UTC

Update

We are investigating reports of slow queue times for Hosted Runners, leading to high wait times.
Posted Aug 21, 2025 - 16:05 UTC

Investigating

We are investigating reports of degraded performance for Actions
Posted Aug 21, 2025 - 15:54 UTC
This incident affected: Actions.