GitHub header

Delays starting Actions runs

Incident Report for GitHub

Update

We are continuing to work on a mitigation.
Posted Jul 09, 2026 - 06:01 UTC

Update

Approximately 5% of GitHub Actions runs on GitHub-hosted runners are experiencing run start delays exceeding 5 minutes. A small portion of these runs may fail after extended delays. We have identified the cause and are working on a mitigation.
Posted Jul 09, 2026 - 04:51 UTC

Investigating

We are investigating reports of degraded performance for Actions
Posted Jul 09, 2026 - 04:34 UTC
This incident affects: Actions.