GitHub header

Disruption with some GitHub services

Incident Report for GitHub

Resolved

On July 16, 2026, between 08:50 UTC and 09:50 UTC, the GitHub MCP Server’s web_search tool experienced elevated failures. The average error rate was 42% and peaked at 82% of requests to the tool. Other GitHub MCP Server tools were unaffected. This was caused by degradation at a downstream web search provider.

The incident was mitigated when the downstream provider recovered, after which we confirmed that the tool’s success rate had returned to normal.

We are improving the tool’s resilience and failure handling to reduce the customer impact and duration of similar incidents.
Posted Jul 16, 2026 - 12:20 UTC

Update

The degradation has been mitigated. We are monitoring to ensure stability.
Posted Jul 16, 2026 - 10:17 UTC

Monitoring

The degradation has been mitigated. We are monitoring to ensure stability.
Posted Jul 16, 2026 - 09:30 UTC

Investigating

We are investigating reports of impacted performance for some GitHub services.
Posted Jul 16, 2026 - 09:13 UTC