GitHub header

Disruption with some GitHub services

Incident Report for GitHub

Resolved

Between 2025-03-27 12:00 UTC and 2025-04-03 16:00 UTC, the GitHub Enterprise Cloud Dormant Users report was degraded and falsely indicated that dormant users were active within their business. This was due to increased load on a database from a non-performant query.

We mitigated the incident by increasing the capacity of the database, and installing monitors for this specific report to improve observability for future. As a long-term solution, we are rewriting the Dormant Users report to optimize how it queries for user activity, which will result in significantly faster and accurate report generation.
Posted Apr 02, 2025 - 20:20 UTC

Update

We are aware that the generation of the Dormant Users Report is delayed for some of our customers, and that the resulting report may be inaccurate. We are actively investigating the root cause and a possible remediation.
Posted Apr 02, 2025 - 19:09 UTC

Investigating

We are currently investigating this issue.
Posted Apr 02, 2025 - 19:08 UTC