GitHub header

Disruption with some GitHub services

Incident Report for GitHub

Update

This issue has recurred. Customers will once again experience false job starts when assigning tasks to Copilot Cloud Agent.

We are still investigating and trying to understand the pattern of degradation.
Posted Apr 02, 2026 - 19:28 UTC

Update

We are once again seeing recovery with Copilot Cloud Agent job starts.

We are keeping this open while we verify this won't recur.
Posted Apr 02, 2026 - 18:25 UTC

Update

When assigning tasks to Copilot Cloud Agent, the task will appear to be working, but may not actually be running.

We are investigating.
Posted Apr 02, 2026 - 17:59 UTC

Investigating

We are investigating reports of impacted performance for some GitHub services.
Posted Apr 02, 2026 - 17:49 UTC