GitHub header

Disruption with some GitHub services

Incident Report for GitHub

Update

We've applied a mitigation to unblock running Actions. We're continuing to monitor.
Posted Apr 28, 2026 - 15:20 UTC

Update

We're still investigating the root cause for run start delays and failures for Actions hosted Ubuntu jobs, around 5% of jobs are impacted as of now.
Posted Apr 28, 2026 - 14:49 UTC

Investigating

Actions is experiencing degraded performance. We are continuing to investigate.
Posted Apr 28, 2026 - 14:02 UTC

Monitoring

Actions is experiencing capacity constraints with hosted ubuntu-latest and ubuntu-24.02, leading to high wait times. Other hosted labels and self-hosted runners are not impacted.
Posted Apr 28, 2026 - 13:59 UTC

Investigating

We are investigating reports of impacted performance for some GitHub services.
Posted Apr 28, 2026 - 13:59 UTC
This incident affects: Actions.