GitHub header

Disruption with Copilot Coding Agent sessions

Incident Report for GitHub

Resolved

This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Posted Mar 19, 2026 - 02:52 UTC

Update

We have rolled out our mitigation and are seeing recovery for Copilot Coding Agent sessions
Posted Mar 19, 2026 - 02:46 UTC

Update

We are seeing widespread issues starting and viewing Copilot Agent sessions. We have a hypothesis for the cause and are working on remediation.
Posted Mar 19, 2026 - 02:25 UTC

Investigating

We are investigating reports of impacted performance for some GitHub services.
Posted Mar 19, 2026 - 02:05 UTC