On August 29th, 2024, from 16:56 UTC to 21:42 UTC, we observed an elevated rate of traffic on our public edge, which triggered GitHub’s rate limiting protections. This resulted in <0.1% of users being identified as false-positives, which they experienced as intermittent connection timeouts. At 20:59 UTC the engineering team improved the system to remediate the false-positive identification of user traffic, and return to normal traffic operations.
Posted Aug 29, 2024 - 21:54 UTC
Update
The connectivity issues have been resolved and we are back to normal.
Posted Aug 29, 2024 - 21:54 UTC
Update
We have implemented a potential fix and are continuing to monitor for success.
Posted Aug 29, 2024 - 21:45 UTC
Update
We have isolated the symptom of the connectivity issues and are working to trace down the cause.
Posted Aug 29, 2024 - 21:25 UTC
Update
While we have seen a reduction in reports of users having connectivity issues to GitHub.com, we are still investigating the issue.
Posted Aug 29, 2024 - 20:43 UTC
Update
We are continuing to investigate issues with customers reporting temporary issues accessing GitHub.com
Posted Aug 29, 2024 - 20:07 UTC
Update
We are getting reports of users who aren't able to access GitHub.com and are investigating.