On January 7th, 2025 between 11:54:00 and 16:39 UTC, degraded performance was observed in Actions, Webhooks, and Issues, caused by an internal Certificate Authority configuration change that disrupted our event infrastructure. The configuration issue was promptly identified and resolved by rolling the change back on impacted hosts and re-issuing certificates.
We have identified what services need updates to support the current PKI architecture and are working on implementing those changes to prevent a future recurrence.
Posted Jan 07, 2025 - 16:39 UTC
Update
Issues is operating normally.
Posted Jan 07, 2025 - 16:39 UTC
Update
Actions is operating normally.
Posted Jan 07, 2025 - 16:38 UTC
Update
Webhooks is operating normally.
Posted Jan 07, 2025 - 16:38 UTC
Update
Webhooks is experiencing degraded performance. We are continuing to investigate.
Posted Jan 07, 2025 - 16:09 UTC
Update
We have identified a configuration issue that we believe is the source of the Action workflow job delays and page latency increases. We are continuing to investigate and mitigate the issue.
Posted Jan 07, 2025 - 15:59 UTC
Update
Issues is experiencing degraded performance. We are continuing to investigate.
Posted Jan 07, 2025 - 15:51 UTC
Update
Users may see delays with Action workflow jobs in the UI and API responses. Additionally, several endpoints, including some Pull Request pages are experiencing increased latency. We are continuing to investigate the issue.
Posted Jan 07, 2025 - 15:17 UTC
Investigating
We are investigating reports of degraded performance for Actions
Posted Jan 07, 2025 - 14:49 UTC
This incident affected: Webhooks, Issues, and Actions.